As zou can see on the picture a I have on the spreadSheetMapper an error,


This is actually not an error, this is because the XML file from the API is blank, there is no orders that why, but when there is sommes orders everything is working perfectly.

My question is, how can I remove this error to show up?

I have tried to select in disableWarnings:

Disable unmapped Values Warning

Disable processing errors (e.g. syntax errors, missing source columns, etc.)

but those are not working, when I select them both the error keep appearing.

Best regrads


You could use a StopFlowIF Step to abort the Flow if the downloaded file is too small.


Thanks for your help but that doesn't works.

in condition I have:

responseSize@UrlDownload_11!?number < 1000

And in errorMessage I have:

File size = ${responseSize@UrlDownload_11!}

note that the file size it's always 0 but when I download the text file I in step 1 is about 2000 bytes.

I also tried with others variables and nothing works.

Best regards


Could you please send us a Screenshot of a Step Preview of the "UrlDownload". Please make sure we see the responseSize output and also the "UrlDownload_11" part.


Here is the screenshot:


So the responseSize is 0 but the downloaded file is about 100 Byte there is only one line.

I have also tried with another flow and this time there is about 200 lines and the responseSize is still 0 but the downloaded file is about 4000 bytes, here is the screenshot:


Thanks for you help

Best regards


Ok thank you we will check that.

Unfortunatelly we were not able to reproduce the problem. In our test the responseSize works.


1. When you say the file actually contains e.g. 1 line or 200 lines .... how did you get the file? Did you use the "Download" link next to the filename as seen in your 1st Screenshot of the Step Preview?

2. Is it possible that the URL you are calling just works one time? e.g. 1st Call: you get the file.... 2nd Call: empty file? Just asking because some APIs may work that way, because they are marking records as exported after calling or so...

3. Can you try the URLDownload with a simple URL e.g. google.com and check if the responseSize is > 0 ?

1) Yes, I have use the "Download" link

2) No, the call can have several times

3) The test is still responseSize = 0

Step to reproduce:

go to https://resttesttest.com/

copy the Endpoint link

in Synesty create a new flow

create a new UrlDownload

past the Endpoint link in to Host


Here is the screenshots:


Here is the URLDownload.json file


So on my side the responseSize is still 0

Thanks for the details... we will continue investigating.

Ok now we could reproduce it. A fix will be worked on.

What you could do in the meantime.

Change your filter condition for StopFlowIF to:

file@UrlDownload_11.length() < 1000