AirtableCreateRecords - Error


I created a flow that adds records in airtable. Flow works partially because it creates records and then it gives me following error massage.

i looked at datasets and saw that one of the datasets has a empty values in it and i think it causes the problem.
Could you please help me with this issue?

best regards,
Heimwerkertools Team

hello @heimwerkertools ,

Can you check at which field you are referring here?

The red error is complaining about the field „Quantity Price 1“.

What value are you trying to send there?

@synesty-Sales thank you for your respond!
yes, field Quantity Price 1 contains number values and empty value. I check this field in airtable too. Flow works till 70th line and then stops and gives this error massage. I check the field the only thing that values are empty.

Thanks for your feedback. We could reproduce the error with a „number“ field in Airtable.
Can you please try again.
We deployed a fix which better handles empty values.

Just for the record: Now our step sends "fieldname" : null to the Airtable API in case a column value is empty.

@synesty-Sales thank you!

Unfortunately, i got another error massage concerning other field. The problem with this field, i think , is that this field has sting values für first 100 datasets and number values for rest.

I don’t know if it is something that you also can change or fix. Please respond as soon as possible! Thank you!

Can you post examples? that would be helpful.

@synesty-Sales for example

Thanks for the info. It seems the mix is the problem. We will get back to you and try to find a fix.

We made a small adjustment on how numeric fields are handled. Can you please retry?

@synesty-Sales i tried

this is what i got

It seems the permission for „Schema Read“ is missing in your personal access token.

Can you please check:

  1. Go to
  2. Go into your token (or create a new one)
  3. Make sure that scope schema.bases:read is in the list of Scopes.

@synesty-Sales thank you the flow worked

1 Like