i want to add rows with information from csv file. i imported csv → used csv reader and airtable createrecord.
Flow is working in Synesty it says that it finished successfully, however when i check it in Airtable the table is unchanged so no rows with information were added.
Please Help


did you check that all the column titles are exactly the same as in your targeted table in airtable?
Please also double check that you’ve selected the right baseid and tablename.

Best regards,


Yes, i did check the column titles in airtable twice.

now i changed the structure

and i get an error
A-4 AirtableCreateRecords: Fehler im (Sub)-Step Mapper - prepare result (3) Die Kopfzeile des Quell-Spreadsheets fehlt. Mögliche Ursache: Manchmal kommt es vor, dass das Quell-Spreadsheet aus XML/JSON Datein geparst wird und während des Parsings Fehler auftreten, so dass das die Kopfzeile nicht erzeugt werden kann.


  • Prüfen Sie den Step, der das Quell-Spreadsheet erzeugt, ob es ein Problem beim Parsing o.Ä. gibt. Manchmal liest der vorherige Step eine kaputte oder leere Datei ein.

Could you please help?


thank you for your response.

We’ll investigate the problem at the moment.
Because of the current vacation time, it could be that we’ll need up to next week to figure out the issue. Sorry for the inconvenience.

Best regards,

Hi @heimwerkertools ,

we verified successfully in our testsystem that the step AirtableCreateRecords works in general. So we can try to assist you in finding out whats going on. We assume a configuration error somewhere, and we try to support you finding it.

So here are our thoughts:

The MISSING_SOURCE_SPREADSHEET_HEADER seems to happen when the Airtable API does not return a Result or maybe an error.
We could simulate this error when we passed an

  • incorrect baseId
  • incorrect tablename
  • or incorrect API-Key in the account.

Also make sure you you have no leading / trailing spaces in any of them. A single space at the end can break everything.

The baseId can be found in the airtable URL here:

and needs to go here:

The APIKey can be found in your Airtable Account page :

and needs to go in an account in Synesty here:

We recommend testing first with a very small new table in Airtable which has e.g. 2 columns.

Can you please create a small CSV manually for testing which looks the test table? You can use the Step StringToFile for that purpose and pass it to the CSVReader.

Here is a small example we used for our testing:

it goes to the Airtable table like this:

Hello @heimwerkertools,

I’ve tested this step yesterday and got the same error as you (I’m completely new to AirTable)

Just in case you’re new too:
The last image from the previous post of my colleague solved my problems. I’ve got an typo in one column title, which caused the step to break.

After I adjusted it, the step works as intended.

So please once again check the column titles of your table to match the submitted ones.

If you’ve not mapped the data directly inside the AirTable Step but in the Mapper before (Step 3) please check that there are no columns present, which don’t exist in your AirTable table.

We’ll update the documentation to be more explicit about that.

Best regards,

i thank you for your answers!
when i do flow: StringToFile → CVSReader → AirtableCreateRecords - everything works perfectly
but when i try this flow: SellerCentralRequestReport → CVSReader → AirtableCreateRecords - it gives me the same error
i even shorten headers to one letter and it still is not working