Connection to Veloconnect working test BUT no data fetch from supplier.

Good morning,
we have a flow to receive data from our supplier.
This flow until some days ago works well with any problem.
For a few days now, we are not able to receive data.
We have tested connection throught "My connection" section and don't have problem.
But into the first step previw of the flow we can't see any data.

My supplier say to me that there isn't any issue from they.

I Kindly need your best help to solve the issue and receive data.

Best Regars,
Michele

Hello Michele,


can you please describe your flow in more detail. In your screenshot we can only see that an error occurs in a Mapper Step. Where is this Mapper Step located in your flow? Is the input of this Mapper Step a result of a Veloconnect Step ? If yes, which Veloconnect Step is it ? Can you pause the previous steps and try to preview the Veloconnect Step ?


Best regards,

Torsten

Hi Torsten,
attached you can see the steps flow, and below I explain all the steps
1) First of all with function VeloconnectTextSearch and "ItemType" into configuration of "result mode" we receive data from veloconnect interface of my supplier. Data includes Sku, Name, Description, Price, Retail Price, Availability etc..
2) Then, the second step is about mapping of the data received with the first function VeloconnectTextSearch. The mapping is done only on two field and not all. Only Sku and then availability. These are the important data for me.
3) Third step is the function CSVWriter, to write the mapped field into a csv with delimiter. This is important in order to import the CSV into my website.
4) Last step is the EmailSend. So from synesty i send email to my email box.
That are the steps.

The issue happens exactly in the first step. The function VeloconnectTextSearch isn't able to receive data. With button "step preview" i'm not able to visualize data.
I did a check, also, in the account connection to veloconnect and from the test button results that i receive data, but into flow it don't happen.

I also tried to change the "result mode" into the first step from the actual "Item Type" to "ID only" but with no results.

I hope i have explained the issue in the best way possible.
Waiting your best and kindly help.

Best Regars,
Michele

From what you describe it sounds like there is just no data coming.

Can you try to enable the Debug Mode of the flow? Download the file, unzip and view it with a Texteditor. Try to search for words like "Error" or "Exception" and check if you see any indication.

When was the last time the flow has worked? (check your eventlog).

1 Like