SpreadsheetUrlDownload Warning überschreiben

Hallo,

ab und an kommt es beim Step SpreadsheetUrlDownload zu 443 Fehlern - Gegenseite (warum auch immer) kein Response. Der Flow läuft weiter und die nächsten REST Calls funktionieren auch wieder, aber der Flow ended schlussendlich mit Status „mit Warnung“.

Da es sich stets um eine temp. Problem auf der Gegenseite handelt greifen wir die fehlgeschlagenen Requests ab und schicken diese zu einem späteren Zeitpunkt im Flow erneut (Stichwort Retry) - bisher gehen die dann auch immer durch :slight_smile:

Können wir den Status des Flows irgendwie auf „Erfolgreich“ setzen wenn der Retry erfolgreich war?
Ein StopFlowIf mit Aktion „Ohne Warnung fortsetzen“ oder „Erfolgreich beenden“ und entsprechender Condition führt leider nicht zum gewünschten Ergebnis.

LG Tim

1 Like

Hallo Tim,

den Status das Runs kannst du „später“ nicht mehr ändern, wenn schon min. eine Warnung geloggt wurde.
Eventuell kannst du den Status Code 443 im Feld errorStatusCodes des 1. SpreadsheetUrlDownload Steps „ausschließen“. Dann wird keine Warnung 443 geloggt. Im 2. SpreadsheetUrlDownload (retry) kannst du das errorStatusCodes Feld leer lassen, damit eine Warnung geloggt wird wenn ein Fehler bei retry auftritt.

Z.B. sollte errorStatusCodes = 4[0-9][^3], 5.* den Status 443 ausschließen und bei allen anderen 4xx bzw. 5xx Status ein Warnung loggen.

Doku: SpreadsheetUrlDownload | Synesty Docs SpreadsheetUrlDownload | Synesty Docs

Viele Grüße
Torsten

Hey,

errorStatusCodes hab ich bereits nur auf 401 (request denied) gesetzt :frowning: Sollte aufs gleiche hinauslaufen oder?

LG Tim

Ja, dass sollte auch funktionieren. Mit errorStatusCodes = 401 sollte auch nur bei HTTP Status = 401 eine Warnung geloggt werden.

Beispiel von gerade eben:
image

Settings:
image

Die Ursache schein hier zu sein, dass überhaupt kein StatusCode retour kommt… hab mich vom Port 443 fehlleiten lassen :face_with_peeking_eye:

statusCode statusMessage error errorMessage
An error happened during a HTTP Request. (Root Causes: NoHttpResponseException: marketplaces.teppichmax.de:443 failed to respond)
An error happened during a HTTP Request. (Root Causes: NoHttpResponseException: marketplaces.teppichmax.de:443 failed to respond)

Neue Herausforderung also :kissing_closed_eyes:

LG Tim

Hallo Tim,

ahh, dass ist der Port 443 (https). Das hat nichts mit dem HTTP status code zu tun.

NoHttpResponseException bedeutet, dass gar keine Antwort kommt (timeout). D.h. wir erhalten auch keine http status. In dem Fall könntest du es nur mal mit einem höheren Wert bei timeoutInSeconds probieren.

Viele Grüße
Torsten